[futurebasic] Re: [FB] Re: Launch e-mail in application

Message: < previous - next > : Reply : Subscribe : Cleanse
Home   : June 2004 : Group Archive : Group : All Groups

From: Brian Stevens <brilor@...>
Date: Sun, 13 Jun 2004 18:32:59 -0700
On Jun 13, 2004, at 5:58 PM, Ken Shmidheiser wrote:

> Robert Covington wrote:
>
>> Dat one worked ok to launch Mail, but the To: field is the only one
>> arriving unscathed (10.2.8)
>>
>> The subject had the entire rest of the cc/bcc/ and body text portion
>> (body had nothing). Didn't auto-separate properly into the correct
>> fields for some reason.
>
>
> Robert,
>
> Do me a favor and remove all the spaces from the subject and text 
> strings (run the words together) and run again to see if they make it 
> intact. You may not need to escape spaces in Mail. The space 
> characters gave me fits here until I discovered I had to escape them 
> foe Eudora.
>
Ken,

Also using Mail, I first  commented out the calls to fn replace$ and 
the result is the subject is "test" (ignoring the word "subject") and 
the TO is correct but all other fields are blank (i.e. nothing for cc, 
bss or body. Removing the space between "test" and "subject" and 
removing the spaces in the message text has the same result Robert saw 
(i.e. everything on the subject line not parsed into their individual 
fields). Apparently, each mail program has its own formatting 
requirements. Thanks for giving me a demo to play with.

Brian



> For those following this thread, Apple suggests a way to send e-mails 
> with attachments from within applications in this tech note:
>
> http://developer.apple.com/qa/qa2001/qa1018.html
>
> I have attempted to run the code directly in AppleScript Editor prior 
> to porting to FB, but Apple's own example doesn't run.
>
> Will keep trying.
>
> Ken
>
> --
>