[futurebasic] FBtoC and Compiled Apps run on Powerbook G3 with OS X 10.2.8

Message: < previous - next > : Reply : Subscribe : Cleanse
Home   : February 2008 : Group Archive : Group : All Groups

From: Rich Love <richlove@...>
Date: Sun, 24 Feb 2008 06:48:05 -0600
The documentation in FBtoC says that you need OS X 10.3.9 or later.
Does that mean that compiled apps need 10.3.9 or later (or is that  
just a requirement for FBtoC to compile the app) ?

I am trying to run a compiled app on a Powerbook G3 with OS X 10.2.8  
and it crashes.
The crash dump report says
can't open library: /usr/lib/libgcc_s.1.dylib  (No such file or  
directory, errno = 2)

It does not matter if it is compiled as a universal app or as PowerPC.
Even a simple app like this fails:
window 1
do
handleevents
delay 10
if mouse(0) <> 0 then print MOUSE(_horz),mouse(_lastmhorz)
until gFBQuit



Rich