[futurebasic] Re: [FB] [X-FB] Xcode

Message: < previous - next > : Reply : Subscribe : Cleanse
Home   : September 2008 : Group Archive : Group : All Groups

From: Ken Shmidheiser <kshmidheiser@...>
Date: Wed, 24 Sep 2008 00:45:03 -0400
Al responded:

> I installed gcc 4.0. Xcode 1.5 wouldn't work with it and FBtoC  
> wouldn't compile with it, so I uninstalled everything and  
> reinstalled Xcode 1.5. I've been stuck ever since.


I don't think you uninstalled everything. I think the gcc version on  
your system is not compatible with Xcode 1.5. Humor me and tell me  
what you get when you enter this in the Terminal:

    gcc --version

You should get this (this is from a Panther machine running 10.3.9):

$ gcc --version
gcc (GCC) 3.3 20030304 (Apple Computer, Inc. build 1666)
Copyright (C) 2002 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There  
is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR  
PURPOSE.

I don't think you will.

In any case I would do an Archive and Install from my installation  
DVD being sure to check the "Preserve user and network settings."  
Once your Unix underpinnings are restored, you should  be able to  
successfully reinstall the Developer Tools that are compatible with  
your OS.

Ken